vB4 is now (almost) compatible with php 8.0!

This is a major upgrade with hundreds of modifications in almost all php files to make vB4 compatible with php 8.0. To get your upgrade, make a payment below and send your vBulletin license number. Yes, you have to be a licensed user to get this working.

This is not a complete vBulletin installation. You will need your original vB4 files from the members' area at vbulletin.com. This package contains only the patched php files.

To keep it affordable for all, the price is set at $150, payable by PayPal.

Once your payment is verified, we will contact you at your PayPal email address within 48 hours and send you the patched files.

Installation:
  1. Backup your database
  2. Backup your forum root folder
  3. Save a copy of your server settings. Take screenshots if needed.
  4. Upload the patched files to your forum root folder and replace existing php files.
  5. Add this line at the top of includes/config.php to disable all add-ons
    define('DISABLE_HOOKS', true);
  6. Go to the php settings on your server and change the php version to 8.0. Make sure to turn off the display errors setting.



Beta release:
PHP 8.0 errors are resolved to the best of our knowledge, but warnings are still there.
You must turn off php error reporting on your server.

If you find any unresolved errors, contact us and we will try to fix them as soon as possible without any extra charge.


This upgrade is only for core vBulletin files. Your additional products and addons will still be incompatible with php 8.0. Contact us to upgrade the addons as well for extra cost.


Warning: PROCEED AT YOUR OWN RISK
Backup your vBulletin installation folder and the database before proceeding with this upgrade. Save a copy of all your server settings. We hold no liability whatsoever for any undesired consequences.